写8日内5,10日金叉,收盘价上穿5日线预警

编写要求:

自己不会编写公式,只有再次麻烦老师了。非常感谢理想老师的热心帮助,也感谢版主耐心解答!下面是具体条件: 1.最近8个交易日内出现过一次5日均线上穿10日均线,两线方向不要求,本次两线交叉点大于上行的120日均线。5日和10日线粘合也算金叉,也可以选出来 2.今日股价上穿5日线预警,股价上穿10日线预警,不要求同时上穿,分别上穿都可以预警。

股票网解答:

A1:=COUNT(CROSS(MA(C,5),MA(C,10)) OR
BETWEEN(MA(C,5),MA(C,10)*1.02,MA(C,10)*0.98),8)>0;
A2:=MA(C,120)>REF(MA(C,120),1);
A3:=MA(C,5)>MA(C,120);
A4:=CROSS(C,MA(C,5))
OR CROSS(C,MA(C,10));
A1 AND A2 AND A3 AND A4;